about xobxob connector application

Generally related to XOBXOB and IoT, that is.
ghostboy017
Posts: 1
Joined: Sun Sep 15, 2013 3:38 pm

about xobxob connector application

Postby ghostboy017 » Sun Sep 15, 2013 4:07 pm

xobxob conncetor application does not shows the serial ports. arduino library part done successfully.. but the problem exits for the application connector..i am in mac OSX lion... need help

xobxob
Posts: 18
Joined: Sat Jul 27, 2013 8:41 am

Re: about xobxob connector application

Postby xobxob » Tue Sep 17, 2013 6:07 am

Has anyone else had problems running the connector on Lion? One possible solution might be run the Connector from it's source code rather than the compiled version that's been uploaded. The Connector was written using Processing. The uploaded Mac Connector was created on Mountain Lion and it's possible it isn't compatible with Lion.

To run the Connector from source code:

1) Download Processing from http://www.processing.org
2) Start Processing and open the .pde file from the directory, XOBXOB_Connector_Mac > Source
3) Run the application by clicking the Run button, or by choosing Run from the Sketch menu

If anyone tries this, it would be great to know if it works!

energia
Posts: 2
Joined: Thu Sep 26, 2013 2:18 am

Re: about xobxob connector application

Postby energia » Thu Sep 26, 2013 2:41 am

I ran into an issue with the connector app on Mac OS X 10.8.4 where pressing any of the letters to select the Serial port did not work.
Running the app from terminal in hope the output in the terminal window would reveal some debug info yields the following:

Code: Select all

Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version   = RXTX-2.1-7
To use the serial library, first open
Applications -> Utilities -> Terminal.app
and enter the following:
sudo mkdir -p /var/lock
sudo chmod 777 /var/lock


After creating /var/lock all is good. What is the reason for needing /var/lock/? RXTX lib can be used without needing this lock file as far as I know.
Anyways, wanted to report this so that a more user friendly solution can be created.

Robert@Energia
http://energia.nu | Wiring for the TI LaunchPad

xobxob
Posts: 18
Joined: Sat Jul 27, 2013 8:41 am

Re: about xobxob connector application

Postby xobxob » Thu Sep 26, 2013 6:31 am

Great information, thanks! The Connector app was built using Processing. It's possible the problem has to do with the Java library Processing is using. The problem doesn't seem to be consistent, though.

xobxob
Posts: 18
Joined: Sat Jul 27, 2013 8:41 am

Re: about xobxob connector application

Postby xobxob » Thu Sep 26, 2013 8:46 am

By the way, we discovered a bug in the Connector application that was preventing it from properly connecting to XOBXOB. A new version fixing the problem has been posted in the download section of XOBXOB and on GitHub.

energia
Posts: 2
Joined: Thu Sep 26, 2013 2:18 am

Re: about xobxob connector application

Postby energia » Thu Sep 26, 2013 2:32 pm

xobxob wrote:By the way, we discovered a bug in the Connector application that was preventing it from properly connecting to XOBXOB. A new version fixing the problem has been posted in the download section of XOBXOB and on GitHub.


I noticed that host was pointing to localhost:8080 rather than www.xobxob.com:80. Is that the bug you are referring to?

Robert

xobxob
Posts: 18
Joined: Sat Jul 27, 2013 8:41 am

Re: about xobxob connector application

Postby xobxob » Thu Sep 26, 2013 8:51 pm

Yes. That's the one. The release was pushed without changing the service pointer from the local dev environment. Too many late nights before Maker Faire. :-)


Return to “General Topics”

Who is online

Users browsing this forum: DJRobert, madelineit16 and 2 guests